New Homepage Forums Basic I/O Shields LED not lighting up

This topic contains 1 reply, has 2 voices, and was last updated by avatar Ahmed ismail 2 years, 7 months ago. This post has been viewed 468 times

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #67577
    avatar[email protected]
    Participant

    I tried out the getting started tutorial, https://www.hackster.io/ahmedismail3115/arduino-based-amazon-echo-using-1sheeld-84fa6f. I am able to connect to 1sheeld app on my phone to the arduino. My issue is the LED does not light up. I have been provided with 3 led’s of 3 different colours (red, green and yellow) by my group project supervisor in college. The leds have 2 pins on each of them. In the video it appears you have a white led and one pin? I tried putting in the shorter pin of my yellow led and then the longer pin. I cannot fit both pins into 1sheeld board. Please let me know how to remedy this as I would like to be successful in this tutorial.

    Kindest regards,
    Jennifer

    #67823
    avatarAhmed ismail
    Keymaster

    Hey Jennifer, actually the LEDs in the tutorial are totally different from the LEDs you have.

    The LEDs in the tutorial are RGB LED strips which have 4 control lines (RGB is for Red, Green, and Blue) which means that one LED can give me a combination of 3 colors, so the 4 control lines where a 12v pin and 3 pins for each color “as illustrated in the design of the tutorial”.

    The LEDs you have are normal LEDs with two pins(Anode “the long leg” and Cathode “the short leg”) and you need to connect the Anode the control pin of the Arduino and the Cathode to the ground. other than that it won’t turn on. So you can’t connect to legs of two LEDs on one control pin of the 1Sheeld you need to connect each one separately. Or if you like to turn them on using 1 control pin you can use a breadboard and connect the Anode of the LEDs on one line with the control pin of the Arduino and all the Cathodes together to the ground.

    Please let me know if there’s anything not clear 🙂

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.